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Introduction to EffectsEd

EffectsEd is a tool for creating and editing effect files (*.efx).  Each effect file describes one effect, which in turn is made up of one or more effect segments.  An effect segment has a primitive type, such as particle, decal, or line, and a set of parameters that describe how many primitives to create and how the primitives will behave.  EffectsEd allows you to create and load effect files, view the segments, add and remove segments, and edit their parameters.  EffectsEd will also play the effect in a test world so you can see (approximately) how the effect will look in the game.

Getting Started

Step 1:  Always run EffectsEd using the k:\UTIL\EffectsEd\runeffectsedlocal.bat batch script.  This allows new versions of EffectsEd to be released while you are using it.

Step 2:  Select the world scale appropriate for the game you are developing, using the pull-down menu in the EffectsEd toolbar.  The world scale is the number of world units that are equivalent to one foot.  EffectsEd has several scales available that should match the games currently in development.  If any of the scales are wrong, or if a new scale is needed, contact the EffectsEd maintainer.

Step 3:  Set the default game path.  Choose “Set Default Game Path…” from the Edit menu, and browse to the “base” directory for your game.  This path will be used to find effects, shaders, textures, and sounds while you are creating a new effect.

Step 4:  Create a new effect segment by clicking on the “New Segment” button in the toolbar (the wand icon) or by selecting “New Segment…” from the Effects menu.  Select “Particle” as the primitive type.  Notice that the new segment appears in the list view at the bottom of the window, and its parameters appear as a property sheet on the right.

Step 5:  In the Generation page on the right, change the two fields labeled “Life” from 0 to 2000.  In EffectsEd, most parameters have two values that define the minimum and maximum of a range.  You must set both of these fields.  Click on the “Apply” button or press Enter to apply the change.

Step 6:  Click on the Motion tab and change the fields as follows:


Velocity:
Forward
100
300




Right

-60
60




Up

-60
60


Gravity:


-800
-800

Click the “Apply” button or press Enter.

Step 7:  Click the “Play” button (the green triangle) in the toolbar, press the spacebar, or select “Play” from the Effects menu.  You should see a white box shoot into the air in the world view.  Click on the “Repeat” button (the green triangle with the circular arrows) and click “Play” or press the spacebar again.  Now you should see white boxes continuously popping up.  You can adjust the repeat rate using the slider to the right of the “Repeat” button.  You can stop a repeating effect by pressing the spacebar, by clicking on the “Repeat” button, or by clicking “Stop” (clicking “Stop” will instantly stop all currently playing primitives).

Step 8:  Play around.  Try changing the color or the size of the box.  Turn on physics and make the particles bounce.  Change the number of particles generated using the “Count” field on the Generation page.  Remember to click the “Apply” button or press Enter whenever you make any changes to an effect segment.

Menus, Toolbars, and Views

The File Menu

The File menu mostly contains standard Windows user interface elements.

Refresh (reload) assets

Select this to rescan the shader directory, and to reload textures, shaders, and effects that the current effect is using from disk.  This is useful if you are editing textures, shaders, or effects that are used in the current effect.  Currently, model and sound files are either not used or are not kept loaded from use to use, so there is no need to reload them.

The Edit Menu

The Edit menu mostly contains standard Windows user interface elements.

Choose Wall Color…

This sets the color of the walls, floor, and ceiling in the world view.  In wireframe mode (see the View menu below), the grid lines will be drawn using this color.

Choose Background Color…

This sets the background color of the world view.  The background color is only visible when the room is not being drawn or if wireframe mode is on (see the View menu below), or if you rotate under the floor or zoom out beyond the walls.

Delete

This deletes the currently selected effect segment.  EffectsEd does not have an Undo facility, so be cautious when deleting segments.

Set Default Game Path…

The default game path is used for locating textures, shaders, sounds, and effects while you are editing a new effect.  You should set this when you first run EffectsEd, and whenever you change games.

The View Menu

Main (Effects, Playback, World) Toolbar, Status Bar

These menu items show and hide the EffectsEd toolbars and status bar.

Draw Axes

This shows and hides the orientation axes in the middle of the world view.  For reference, each axis line is 16 world units long.

Draw Room

This switches between drawing the testing room and drawing a large open plane.

Draw Wireframe

This switches between drawing the walls, ceiling, and floor or the testing room or plane as solid surfaces, or as wireframe grids.  When wireframe mode is on, the grid squares are one foot per side.

Reset/zero view position

This resets the view position to the default.

Screenshot to file (clipboard)

These save the world view image to a file on your C: drive, or to the clipboard, so you can paste it into another program.

OpenGL Driver Info

This displays information about the OpenGL driver you are using.

The Effects Menu

New Segment…

This creates a new effect segment and adds it to the effect.  You will be prompted to choose the primitive type for the new segment.

Segment Enabled

This shows and changes the state of the currently selected effect segment.  Disabled segments will not be played in the editor.  Enabling and disabling segments does not affect what gets saved in the effect file – all segments will be played in the game.

Play

This plays the effect.  If repeat is enabled, the effect will be played repeatedly until play is pressed again, repeat is disabled, or stop is pressed.

Pause

This pauses the effect system.  Any primitives in the world will stay in the world.  You can move around in the world view while the system is paused.

Stop

This terminates all currently playing primitives, and stops any repetition of the effect.  If you want to stop a repeating effect and let the primitives continue to play normally, turn repeat off instead of choosing stop.

Repeat

This turns repeat on and off.  After turning repeat on, choose play to start the effect.

Orient Up (Sideways)

This sets the effect axis to be upwards, along the world’s Z axis, or to be sideways, along the world’s X axis.

The Help Menu

The Help menu displays the about box, which isn’t very helpful.

The Main Toolbar

The Main toolbar contains standard Windows user interface elements.

The Effects Toolbar

The Effects toolbar contains two buttons: “New Segment” (the wand icon) and “Delete Segment” (the X icon).  These are equivalent to the corresponding items in the Effects menu.

The Playback Toolbar

The Playback toolbar contains buttons for “Play,” “Pause,” “Stop,” “Repeat,” “Orient Up,” and “Orient Sideways.”  These are all equivalent to the corresponding items in the Effects menu.  It also has a “Repeat Rate” slider.

The World Toolbar

The World toolbar contains three items:  the “World Scale” pull-down menu, the “Time Scale” slider, and the “Draw Axes,” “Draw Room,” and “Draw Wireframe” buttons.  The buttons are equivalent to the corresponding items in the View menu.

World Scale

This sets the number of world units that are equivalent to one foot in real life.  Because different games use different scales, and the scale affects how an effect will look relative to the surrounding environment and viewing distance, it is important to set this correctly.  If you change games, be sure to change this setting appropriately.

Time Scale

This can be used to speed up or slow down the playback of an effect in the editor.  It does not affect how the effect will play back in the game.

The World View

The world view shows the testing room and any currently playing primitives.  You can move about the testing room using the mouse:  use the left button to orbit the room’s center point, and the right button to dolly forward and back.  The left mouse button combined with the Alt key will slide you sideways or up and down, and the left mouse button combined with the Z key will roll you about some axis.

Pressing the spacebar is equivalent to pressing the “Play” button.  This behavior is application wide – it doesn’t matter what view or control has the keyboard focus.

The Segment List View

The list view shows all the segments in the effect.  Each segment can be enabled or disabled by clicking on the checkbox by its name.  A segment can be selected for editing by clicking on it.  The name of a segment can be edited by clicking on a segment when it is already selected.  The order of the segments can be changed by clicking on the header of a column – click once to sort by that column in ascending order, and click again to sort in descending order.

The Segment Property Sheet

When an effect segment is selected, a property sheet will appear on the right side of the window for editing the segment’s parameters.  There will always be a Generation page and an Origin/Size page, but the other pages will depend on the primitive type of the segment being edited.

Most of the parameters have two edit boxes side-by-side.  These define the minimum and maximum values in a range.  Each time a primitive is spawned, its parameter values will be chosen randomly from within each range.  If you want to specify a single value, set that value as both the minimum and maximum for the range.

Changes that you make to a property page will not take effect until you click the Apply button.  Pressing the Enter key in a property page will also apply your changes (unless you are editing a multi-line edit field).  If you try to play the effect or leave the page without clicking Apply, the editor will prompt you to apply your changes.  Be especially sure to click Apply or press Enter when editing an effect that is playing repeatedly, as the changes will not be realized until you do.

Effect Primitives

Supported Primitives

· Particles ( sprites )

· Decals ( oriented polygons, projected onto architecture )

· OrientedParticles ( similar to a decal, but not projected.  Generally more flexible )

· Lines

· Tails ( resemble a comet, orienting itself in the direction of travel )

· Cylinders

· Emitters

· FxRunners

· Sounds

· CameraShake

· Lights

Particles

Particles ( sprites ) are one of the most useful effects primitives since they are viewable from any angle.  Because of this property, they tend to appear to have volume.

Decals

Decals ( oriented polygons ) always face in the user specified direction, but don’t necessary have to be limited to being attached to architecture in the form of a burn or damage mark.  So while they can also move through the world, you have to be careful about how they are used since, by definition, they don’t compensate for any arbitrary viewing angle.  This means that an oriented quad that is floating in mid-air will look fine if viewed head-on, but if viewed from the side, it will appear paper thin.

Lines

Lines are specified by a start and endpoint and the fx system will rotate around this to attempt to keep the bulk of it always viewable at any give time.  For the most part this will work fine, but when viewed from the top, the line will not appear to have any thickness.  Lines are currently not able to move in the existing effects system.  If you need motion abilities, consider trying a tail ( comet-like effect ).

Tails

Tails are comet-like effects primitives.  You can think of them as moving lines that will always orient the length of the line in the direction it is currently traveling in.  Like lines, they will look not appear to have any thickness if viewed directly down its length.

Cylinders

Cylinders are rendered without a top or bottom and have the ability to change height and have the top and bottom radius affected separately.  This ability allows them to be tapered in interesting ways to make specialty effects that would be otherwise hard to simulate.

Emitters

Emitters are primarily used for things like model chunks, and especially, model chunks that have an attached effect.  This could be used in an explosion that throws out chunks that leave a fiery, smoky trail.  The emitter also provides controls for the effects it spews off, allowing you to control the calling density and variation so that you can more easily get frame-rate independent results.

FxRunners

FxRunners exist solely to play other effects.  This is useful because, once you’ve created a few basic effects, like smoke/sparks/whatever, you can reuse these base effects when building new effects instead of having to build effects completely from scratch every time. You should use caution when using can fxRunner, specifically, pay attention to how many effects are being created in the effect you intend to call with this.  Also make sure that you don’t somehow have the fxRunner call the file that it’s in.  If people end up doing this a fair amount, it might make sense to put in some safety guards, but until then, don’t have an fxRunner call itself.

Sounds

Sounds are played at whatever the effect origin specifies.  There currently is no support for controlling volume, so the sound file itself determines the playback volume.  Sound attenuation ( radius fall-off ) is also not supported.  If these features are added to the Q3 sound engine, the effects system can be enhanced to allow access to these abilities.

CameraShake

Camera shakes can affect the camera during cinematics or regular first-person game play.  The shake function considers distance from where the shake was requested to wherever the camera is at that point, so the intensity will naturally fall off as you get further away from it.  You can additionally specify an effect radius, a shake duration and intensity.

Lights

The Light primitive gives access to dynamic lights in the game.  The current dynamic light method that Q3 uses projects a very tall light cylinder in the world so you’ll likely want to check out the results in a variety of situations to determine how Q3 dynamic lights look and whether you want to consider using them.  On the other hand, for very quick flashes, they will probably be sufficient.

Fx Transitions

Transition functions work in a similar fashion for Alpha, RGB, Size, Size2, and Length groups.  Note that not all of these groups listed are available for every primitive type, however, understanding how one groups’ transitions work, we can get a good start in visualizing how other groups work.

We’ll start with listing the main transitions then describe how they can be combined for more complicated transitions.   All examples will relate to Size, but remember that they can easily be applied to other groups.  So, the main list:

· Linear

· Nonlinear

· Clamp

· Wave

· Random

Linear

The linear transition is probably the most useful transition, blending smoothly from the desired start value to the desired end value.  In the case of size, you could use this to have a smoke puff particle start at a size of 4 units and evenly scale to 10 units over the life of the particle.
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Non-Linear

The non-linear transition stays at the desired start value until a certain percentage of the particle life has expired, then it transitions smoothly to the desired end size.  Control of the percentage is exercised by entering a parameter ( Size Parameter in the case of the Size group ) in the range of 0 to 100.  You might use this for a smoke puff that you want to stay at a size of 4 units until 50 percent of the particle life has expired, then evenly blend to the end size of 10 units in the remaining 50 percent of life.
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Clamp

The clamp transition moves from the desired start value to the desired end value during the specified percentage of life, then stays at the end size for the remainder of the life.  Control of the percentage is exercised by entering a parameter ( Size Parameter in the case of the Size group ) in the range of 0 to 100.  You might use this for an explosion sprite that you want to quickly grow from a size of 4 units to 10 units, then stay clamped at 10 units for the remainder of its life.
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Wave

The wave transition resembles a sine wave, pulsing between Size Start and Size End, using the Size Parameter to set the desired frequency.  You might use this for a flame thrower particle, using a variety of sized particles each pulsing at a variety of rates.
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Random

The random function randomly chooses a value between zero and the Size Start field, selecting a series of new values over time.  One might use this transition to create energy –like particles.
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Blending Functions

While you can use the base transition functions by themselves, you can potentially combine them together to get more sophisticated transitions.  Some combinations will naturally be more useful than others.  Also some combinations just aren’t supported, specifically, the Wave, Clamp and Non-Linear transitions share the Size Parameter field, so they aren’t allowed to co-exist. 

The simplest way to think about blended transitions is to imagine them as a 50 percent blend of each of the functions you choose.   For example: start with a linear size transition, having a start size of 4 units then blending to a size of 10 units at the end of its life.  Now if we were to take a non-linear transition with the same start and end size and apply a Size Parameter of 50, the graph of the described blend of the transitions would be similar to the following:
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Here’s a couple of other sample graphs to give you some ideas of what’s possible.
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Troubleshooting

If You Don’t See Anything

· On the Generation page of your effect segment, make sure the Life parameter is large enough for the primitives to be visible.  Lifetimes less than 100 milliseconds may be difficult to see.

· On the Color page, if you use the Shaders edit box to apply a shader that uses GL_SRC_ALPHA for the source blend mode, make sure you uncheck the “Modulate RGB value using alpha value” checkbox and set the alpha parameters to nonzero values.  When “Modulate RGB value using alpha value” is checked, the source alpha value is zero.

· If you are using a projected Decal primitive, make sure you have a shader set on the Color page.  Decals do not draw unless they have a shader attached.

· On the Generation page, make sure the Count is not zero.

· On the Size page, make sure the size is not zero.

· On the Motion page, make sure the velocity, acceleration, and gravity settings are not so high that the primitive disappears before it can be seen.

Known Bugs

· File parsing can be thrown off by trailing white space (spaces and tabs) after closing square brackets.  The editor crashes if a file contains an empty shader/sound/model/effect list.

· Sounds don’t work.  Neither do camera shakes.  And I pretty much guarantee that lights will not look anything like they will in the game.  Also, models always appear as black cubes.

· Things sitting on the floor will fall through the floor.

· Click on “New Segment” when a segment is selected, then click cancel.  The segment should be reselected.

· Cloning an effect leaves the parameters tab in an incorrect state.  Simply select another primitive in the list, then go back to the cloned effect to update it properly.

· The camera shake amount does seem to get set correctly in the editor.  Viewing the .efx file in text format is currently the only way to verify that the applied settings are correct.

